quick one: ruby updates

I discovered that Mavericks (10.9.5) comes with ruby 2.0.0p481 installed. Seeing how Ruby 2.1.4 has been released, I decided to figure out how to get to the newest version. I think a big chunk of it has to come through RVM / Jewelry box (app). I also think I need the brew package management system to make sure everything comes in the right place with all the required packages.

This page seems to have the best, most up-to-date instructions I’ve found on installing the whole Ruby/RVM business.

  • I installed the command line tools. I already have Xcode 6.1 installed, but I installed the command line tools through the command line, just to match the instructions.
  • gcc looks good
  • I already installed HomeBrew when I installed Python 3.4. It looks OK. I get a message about a file I don’t recognize, but I’m not going to worry about it
  • I updated git. Now it’s v 1.9.3, which is what it was before. “which git” does point to the correct version, /usr/local/bin/git
  • installed RVM, but it looks likeĀ are problems. However, version checks look OK
    • rvm -v > rvm 1.26.0
    • problem with ruby: dyld: Library not loaded: /usr/local/lib/libgmp.10.dylib
      • suggested: rvm reinstall 2.1.4 –disable-binary
    • ruby -v > ruby 2.1.4p265
    • rails -v not initially installed (odd)
      • “sudo gem install rails” could be an issue with sudo permissions
      • rails -v > 4.1.7

quick note: forced relocation

Reddit used to have three offices (SF – main, Salt Lake City – redditgifts, NYC – ads). They just received $50 million from VC. They also plan on consolidating their offices. Everybody not in San Francisco has until the end of the year to move out there. Spectacularly dumb idea. Some suspect secret layoffs. In fact, it’s a plan to burn through $50 million as quickly as possible. Dumb.